So-net無料ブログ作成

VirtualBox のインストール方法 [Vine Linux]

ということでインストール方法を簡単に。
(うちは Vine Seed だけど多分 Vine 4.1 でも同じだと思う)

まずインストール前に一手間。

インストール時にディストリビューションを判定して設定
ファイルのインストール方法を切り替えるようなので、
これが上手く働くように

# ln -s /etc/vine-release /etc/redhat-release


としておく。

次に DL したファイルを、

$ chmod +x VirtualBox-1.4.0_21864_fedora7-1.i586.rpm.run
$ ./VirtualBox-1.4.0_21864_fedora7-1.i586.rpm.run


としてライセンスに同意すると rpm ファイルが解凍されるので、

# rpm -Uvh VirtualBox-1.4.0_21864_fedora7-1.i586.rpm


としてインストール。

最後に VirtualBox を使うユーザを vboxusers グループに
追加すれば完了。

後はメニューから GUI の管理ツールを起動して、仮想マシン
を新規に作成してゲスト OS をインストールすれば OK。

# Guest Additions のインストールは次回に続く。


nice!(0)  コメント(6)  トラックバック(0) 
共通テーマ:パソコン・インターネット

nice! 0

コメント 6

iku

はじめまして。自分は今までWindowsUserで最近Linuxに切り替えて勉強している者です。自宅はFCなのですが、NotePCにVINEをインストールしています。このNotePCでVirtualBoxを使いたくググってこのブログに行き着きました。とても参考になって毎回ありがたく参考にさせて頂いております。

今回質問があってコメントさせていただきました。こちらにコメントしていいのかもわからない状態ですが、何卒よろしくご鞭撻ください。

質問は、上記を参考にDLしたVirtualBoxを回答するところまではうまく行ったのですが、インストールを実行する時にパッケージ依存がでてしまい、中のいくつかはaptでうまくいったのですが、下記3つがどうにもなりません。

"libcrypto.so.6","libdbus-1.so.3","rtld(GNU_HASH)です。VINEは4.1で、DLしたVirtualBoxは上記とまったく一緒です。

そのほか何か必要な情報がありましたら是非ご指導ください。
長々と申し訳ございませんが、何卒お付き合いください。
by iku (2007-07-24 14:05) 

kazu

見てみましたが、それぞれ openssl, dbus, glibc の新しいバージョンが必要なようです。

ということで、代わりに RHEL4 向けのバイナリを DL して依存情報を見て見たのですが、これなら Vine 4.1 にも入れられそうです。(実際にインストールまではしてませんが。)

一度試してみて、良かったら結果を教えてください。
by kazu (2007-07-25 21:47) 

iku

早速ご対応頂本当にありがとうございます!!
早速試してみます。結果またUpしますのでその時はまたよろしくお願いいたします。
by iku (2007-07-26 00:01) 

iku

お疲れさまです。上記助言下さった通りRHEL4.1向けのバイナリをDLして試みてみたのですが・・・以下のようになってしまいました。
[root@localhost Desktop]# rpm -Uvh VirtualBox-1.4.0_21864_rhel4-1.i586.rpm エラー: 依存性の欠如:
libSDL-1.2.so.0 は VirtualBox-1.4.0_21864_rhel4-1.i586 に必要とされてい ます
libqt-mt.so.3 は VirtualBox-1.4.0_21864_rhel4-1.i586 に必要とされていま す
libstdc++.so.6 は VirtualBox-1.4.0_21864_rhel4-1.i586 に必要とされています
libstdc++.so.6(CXXABI_1.3) は VirtualBox-1.4.0_21864_rhel4-1.i586 に必要とされています
libstdc++.so.6(GLIBCXX_3.4) は VirtualBox-1.4.0_21864_rhel4-1.i586 に必 要とされています

System依存でしょうか・・・何回かVineを再インストールしてチャレンジはしているのですが・・・お手上げです。オライリーの本読んでソースRPMからコンパイルするしかないのでしょうか・・・
by iku (2007-07-26 03:22) 

ikuo

すみません!!追加です。半ばヤケクソでAptを使ってRHEL4ー1をDLインストールしたら下記のように出来てしまいました・・・

[root@localhost Desktop]# apt-get install VirtualBox-1.4.0_21864_rhel4-1.i586.rpm
パッケージリストを読みこんでいます... 完了
依存情報ツリーを作成しています... 完了
'VirtualBox-1.4.0_21864_rhel4-1.i586.rpm' として VirtualBox を選択しました
以下の追加パッケージがインストールされます:
SDL VirtualBox libmng libstdc++34 qt
以下のパッケージが新たにインストールされます:
SDL VirtualBox libmng libstdc++34 qt
アップグレード: 0 個, 新規インストール: 5 個, 削除: 0 個, 保留: 0 個
6199kB/20.8MB のアーカイブを取得する必要があります。
展開後に 50.9MB のディスク容量が追加消費されます。
続行しますか? [Y/n]y
取得:1 http://updates.vinelinux.org 4.1/i386/plus SDL 1.2.11-0vl0 [204kB]
取得:2 http://updates.vinelinux.org 4.1/i386/plus libmng 1.0.9-0vl1 [215kB]
取得:3 http://updates.vinelinux.org 4.1/i386/plus qt 3.3.5-0vl9.1 [5142kB]
取得:4 http://updates.vinelinux.org 4.1/i386/plus libstdc++34 4.0.2-0vl3 [638kB]6199kB を 25s 秒で取得しました (243kB/s)
変更を適用しています...
準備中... ########################################### [100%]
1:SDL ########################################### [ 20%]
2:libmng ########################################### [ 40%]
3:qt ########################################### [ 60%]
4:libstdc++34 ########################################### [ 80%]
5:VirtualBox ########################################### [100%]

Creating group 'vboxusers'. VM users must be member of that group!

No precompiled module for this kernel found -- trying to build one. Messages
emitted during module compilation will be logged to /var/log/vbox-install.log.

Success!

完了

何故かはこれからいろいろ考えてみたいと思います。ありがとうございました。これからも懲りずにやっていきますので又、何かありましたらよろしくお願いいたします!!
by ikuo (2007-07-26 03:30) 

kazu

apt を使ってインストールするのは全然問題ないですよ。
あまり明確に書いてないと思いますが、apt は普通にローカルの rpm ファイルのインストールに使えます。

私自身も、apt-get install -s VirtualBox-1.4.0_218 64_rhel4-1.i586.rpm と実行して、必要なパッケージが Vine のリポジトリにあることを確認して、前回のコメントを書いていますので。

後は問題なく起動してくれれば良いのですが…。
by kazu (2007-07-26 22:20) 

コメントを書く

お名前:[必須]
URL:
コメント:
画像認証:
下の画像に表示されている文字を入力してください。

トラックバック 0

この広告は前回の更新から一定期間経過したブログに表示されています。更新すると自動で解除されます。

×

この広告は1年以上新しい記事の更新がないブログに表示されております。